Акт из 1с в excel

Акт оказанных услуг в 1С 8.3: заполнение, бланк и образец в Excel

Акт из 1с в excel

Рассмотрим как провести Акт выполненных работ в 1С 8.3 Бухгалтерия 3.0 различными способами. В том числе, изучим способ, который позволяет выписать Акты сразу нескольким контрагентам на одну услугу. Это удобно, когда одну и ту же услугу организация оказывает сразу нескольким контрагентам.

Скачать бланк и образец акта выполненных работы в Excel из 1С:

  • Пустой бланк акта
  • Образец заполнения

Как составить Акт выполненных работ

Когда организации или фирма и физическое лицо, заключают между собой договор на выполнение услуг, выполнение под заказ определенного объема работ и так далее, то к договору обязательно составляется Приложение. В нем фиксируется форма отчета о фактическом объеме выполненных работ или услуг, а также стоимости и сроков исполнения, качестве выполненных работ или услуг.

После окончания выполнения работ или услуг составляется двусторонний документ. Такой документ называется  Акт выполненных  работ, в котором обязательно должна отразиться следующая информация:

  • Дата, номер Акта;
  • Исполнитель – организация;
  • Заказчик – организация;
  • Основание – номер договора;
  • Наименование работы или услуги;
  • Количество, объем, цена;
  • Сумма – стоимость выполненных работ с учетом НДС;
  • Оценка выполненных работ, сроки, качество;
  • Реквизиты контрагентов, заключивших сделку, подтверждающих выполнение услуг;
  • Двусторонние подписи руководителей.

Этот документ является отчетом Исполнителя перед Заказчиком о выполнении договорных обязательств.

На законодательном уровне форма Акта выполненных работ не утверждена, и контрагенты имеют право разрабатывать ее самостоятельно. Главное, чтобы в этой форме была отражена вся необходимая информация по выполнению договорных обязательств.

Как сделать Акт выполненных работ в 1С 8.3

Акт выполненных работ является главным основанием для ввода информации в программу 1С 8.3 Бухгалтерия 3.0.

Способ 1. Через документ Реализация (акты, накладные)

В редакции 1С 8.3 Бухгалтерия 3.0 Акт выполненных работ или услуг формируется на основании следующей первичной информации: выбираем раздел Продажи, переходим в подраздел Продажи, далее в раздел Реализация (акты, накладные):

Далее:

  • Выбираем контрагента, то есть организацию, с которой заключили договор на выполнение работ или услуг из справочника Контрагенты. Пошаговая инструкция работы с контрагентами в 1С 8.3 рассмотрена в следующей статье.
  • С помощью закладки Реализация указываем, что конкретно по договору необходимо выполнить – оказать услугу и так далее;
  • Вид операции – услуги:

После заполнения всей информации по сделке в 1С 8.3 записываем ее и проводим документ. Проверяем проводки и с помощью кнопочки Печать выбираем ту форму документа, которая соответствует всем условиям выполнения договорных обязательств:

Распечатываем этот документ обязательно в двух экземплярах для каждой стороны, проверяем правильность отражения всех данных и передаем на подпись руководителю. Закрепляем печатью. Внешняя печатная форма Акта выполненных работ в 1С 8.3:

Оба экземпляра Акта передаются Заказчику, который подписывает, ставит печать. При этом один экземпляр, подписанный и с печатью, отправляет обратно Исполнителю. Таким образом Заказчик подтверждает, что претензий к выполненным услугам или работам не имеет.

На основании этого Акта выплачивается сумма Исполнителю за выполненную работу (услугу). Когда Заказчик не согласен как была выполнена работа либо оказана услуга, он может не подписывать данный Акт или при подписании оговаривает свои претензии, что согласен оплатить частично по Акту с учетом того, что в дальнейшем Акт выполненных работ будет перевыставлен либо переделан.

Способ 2. Через документ Оказание услуг

В программе 1С 8.3 существует еще один способ формирования Акта выполненных работ. Он очень удобен, когда одну и ту же услугу фирма предоставляет сразу нескольким контрагентам.

В разделе Продажи есть отдельный документ Оказание услуг. В обычном варианте, если выбрана выборочная функциональность, он не отображается. Но при полной функциональности в 1С 8.3 можно с ним работать:

Создаем документ сразу на нескольких контрагентов:

Вводим информацию в 1С 8.3: на закладке Контрагенты с помощью кнопочек Добавить, Заполнить вводятся сразу несколько контрагентов:

Записываем, проводим и проверяем проводки:

Программа 1С 8.3 сразу в одном документе рассчитала данные по контрагентам. Далее формируем печатную форму Акта выполненных (оказанных) услуг. Видим, что программа 1С 8.3 сформировала два Акта по двум контрагентам:

  • По первому контрагенту образец Акта выполненных работ в 1С:
  • По второму контрагенту Акт выполненных работ в 1С 8.3 внешняя печатная форма:

Проверяем по отчету в 1С 8.3. Оба контрагента «попали» в оборотно-сальдовую ведомость:

Очень удобно использовать эту форму Оказания услуг для ввода информации сразу по нескольким контрагентам при создании Акта выполненных работ в 1С 8.3.

Разобраться с тем, где какие документы и справочники находятся в программе 1С 8.

3, какие действия программа предпринимает автоматически, а какие Вам придется делать самостоятельно, как настроить программу «под себя», какой порядок оформления документов и регламентной отчетности действует в программе – все это Вы можете узнать на нашем дистанционном курсе по работе в 1С Бухгалтерия 8 ред. 3.0. Подробнее о курсе смотрите в следующем видео:

Поставьте вашу оценку этой статье:
Загрузка… Поставьте вашу оценку этой статье:
Загрузка…

Источник: https://ProfBuh8.ru/2018/11/akt-vyipolnennyih-rabot-v-1s-8-3/

Работа с файлами Excel

Акт из 1с в excel

MS Excel давно стал стандартом для работы с электронными таблицами. В статье рассматриваются способы программной выгрузки и загрузки из 1С в файлы Excel.

Существует несколько способов программной работы с файлами Excel из 1С. Каждый из них имеет свои преимущества и недостатки.

Обмен через табличный документ
Обмен через OLE
Использование COMSafeArray
Обмен через ADO
Выгрузка без программирования

Обмен через табличный документ

Данный способ простой. Его суть заключается в том, что объект ТабличныйДокумент имеет методы:

  • Записать(, ) для выгрузки данных в файл;
  • Прочитать(, ) для загрузки данных из файла.

Внимание!

Метод Записать() доступен как на клиенте, так и на сервере. Метод Прочитать() доступен только на стороне сервера. Необходимо помнить об этом
при планировании клиент-серверного взаимодействия.

Рассмотрим пример сохранения табличного документа в файл. Необходимо любым способом создать и заполнить объект ТабличныйДокумент, а выгрузка в файл осуществляется всего лишь одной строкой:

ТабДок.Записать(ПутьКФайлу, ТипФайлаТабличногоДокумента.XLSX);

Здесь ТабДок — сформированный табличный документ, ПутьКФайлу — имя файла для выгрузки, ТипФайлаТабличногоДокумента.XLSX — формат создаваемого файла. Поддерживаются следующие форматы Excel:

  • XLS95 — формат Excel 95;
  • XLS97 — формат Excel 97;
  • XLSX — формат Excel 2007.

Загрузка из файла осуществляется также достаточно просто:

ТабДок = Новый ТабличныйДокумент;
ТабДок.Прочитать(ПутьКФайлу, СпособЧтенияЗначенийТабличногоДокумента.Значение);

Здесь ПутьКФайлу — путь к загружаемому файлу Excel. СпособЧтенияЗначенийТабличногоДокумента.Значение определяет, каким образом нужно интерпретировать данные, считываемые из исходного документа. Доступны варианты:

Обмен через OLE

Обмен через технологию OLE automation, пожалуй, самый распространенный вариант программной работы с файлами Excel. Он позволяет использовать весь функционал, предоставляемый Excel, но отличается медленной скоростью работы по сравнению с другими способами. Для обмена через OLE требуется установка MS Excel:

  • На компьютере конечного пользователя, если обмен происходит на стороне клиента;
  • На компьютере сервера 1С:Предприятие, если обмен происходит на стороне сервера.

Пример выгрузки:

// Создание COM-объекта
Эксель = Новый COMОбъект(«Excel.Application»);
// Отключение вывода предупреждений и вопросов
Эксель.DisplayAlerts = Ложь;
// Создание новой книги
Книга = Эксель.WorkBooks.Add();
// Позиционирование на первом листе
Лист = Книга.Worksheets(1);

// Запись значения в ячейку
Лист.Cells(НомерСтроки, НомерКолонки).Value = ЗначениеЯчейки;

// Сохранение файла
Книга.SaveAs(ИмяФайла);

// Закрытие Эксель и освобождение памяти
Эксель.Quit();
Эксель = 0;

Примеры чтения:

// —— ВАРИАНТ 1 ——

// Создание COM-объекта
Эксель = Новый COMОбъект(«Excel.Application»);
// Открытие книги
Книга = Эксель.Workbooks.Open(ПутьКФайлу);
// Позиционирование на нужном листе
Лист = Книга.Worksheets(1);

// Чтение значения ячейки, обычно здесь располагается цикл обхода ячеек
ЗначениеЯчейки = Лист.Cells(НомерСтроки, НомерКолонки).Value;

// Закрытие книги
Книга.Close(0);

// Закрытие Эксель и освобождение памяти
Эксель.Quit();
Эксель = 0;

// —— ВАРИАНТ 2 ——

// Открытие книги
Книга = ПолучитьCOMОбъект(ПутьКФайлу);
// Позиционирование на нужном листе
Лист = Книга.Worksheets(1);

// Чтение значения ячейки, обычно здесь располагается цикл обхода ячеек
ЗначениеЯчейки = Лист.Cells(НомерСтроки, НомерКолонки).Value;

// Закрытие книги
Книга.Application.Quit();

Для обхода всех заполненных строк листа Excel можно использовать следующие приемы:

// —— ВАРИАНТ 1 ——
КоличествоСтрок = Лист.Cells(1, 1).SpecialCells(11).Row;
Для НомерСтроки = 1 По КоличествоСтрок Цикл
     ЗначениеЯчейки = Лист.Cells(НомерСтроки, НомерКолонки).Value;
КонецЦикла;

// —— ВАРИАНТ 2 ——
НомерСтроки = 0;
Пока Истина Цикл
     НомерСтроки = НомерСтроки + 1;
     ЗначениеЯчейки = Лист.Cells(НомерСтроки, НомерКолонки).Value;
     Если НЕ ЗначениеЗаполнено(ЗначениеЯчейки) Тогда
         Прервать;
     КонецЕсли;
КонецЦикла;

Вместо последовательного обхода всех строк листа можно выгрузить все данные в массив и работать с ним. Такой подход будет быстрее при чтении большого объема данных:

ВсегоКолонок = Лист.Cells(1, 1).SpecialCells(11).Column;
ВсегоСтрок = Лист.Cells(1, 1).SpecialCells(11).Row;

Область = Лист.Range(Лист.Cells(1, 1), Лист.Cells(ВсегоСтрок, ВсегоКолонок));
Данные = Область.Value.Выгрузить();

В таблице ниже приведены наиболее востребованные свойства и методы для работы с Excel через OLE:

ДействиеКод

Источник: https://pro1c8.ru/obmen-excel-1c/

Акт из 1С в Excel

Акт из 1с в excel

Когда организации или фирма и физическое лицо, заключают между собой договор на выполнение услуг, выполнение под заказ определенного объема работ и так далее, то к договору обязательно составляется Приложение. В нем фиксируется форма отчета о фактическом объеме выполненных работ или услуг, а также стоимости и сроков исполнения, качестве выполненных работ или услуг.

После окончания выполнения работ или услуг составляется двусторонний документ. Такой документ называется Акт выполненных работ, в котором обязательно должна отразиться следующая информация:

  • Дата, номер Акта;
  • Исполнитель – организация;
  • Заказчик – организация;
  • Основание – номер договора;
  • Наименование работы или услуги;
  • Количество, объем, цена;
  • Сумма – стоимость выполненных работ с учетом НДС;
  • Оценка выполненных работ, сроки, качество;
  • Реквизиты контрагентов, заключивших сделку, подтверждающих выполнение услуг;
  • Двусторонние подписи руководителей.

Этот документ является отчетом Исполнителя перед Заказчиком о выполнении договорных обязательств.

На законодательном уровне форма Акта выполненных работ не утверждена, и контрагенты имеют право разрабатывать ее самостоятельно. Главное, чтобы в этой форме была отражена вся необходимая информация по выполнению договорных обязательств.

Как сделать Акт выполненных работ в 1С 8.3

Акт выполненных работ является главным основанием для ввода информации в программу 1С 8.3 Бухгалтерия 3.0.

Поделиться:
Нет комментариев

    Добавить комментарий

    Ваш e-mail не будет опубликован. Все поля обязательны для заполнения.